# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\d+(?:_\d+)?(?:_[A-Za-z]+)?$/$1/gm;t' <<< "1234567890
1234567890_Alphabet
1234567890 - Alphabet
1234567890alphabet
The string should start as numeric but not alphabet. i.e. Numeric only
Underscore(_) preceded by numbers.
11244422_134444_john
1234322_1234431 john
1234222_134322-john
12422344_12453222"