const regex = new RegExp('^\\d+(?:_\\d+)?(?:_[A-Za-z]+)?$', 'gm')
const str = `1234567890
1234567890_Alphabet
1234567890 - Alphabet
1234567890alphabet
The string should start as numeric but not alphabet. i.e. Numeric only
Underscore(_) preceded by numbers.
11244422_134444_john
1234322_1234431 john
1234222_134322-john
12422344_12453222`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);