using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d+(?:_\d+)?(?:_[A-Za-z]+)?$";
string substitution = @"$1";
string input = @"1234567890
1234567890_Alphabet
1234567890 - Alphabet
1234567890alphabet
The string should start as numeric but not alphabet. i.e. Numeric only
Underscore(_) preceded by numbers.
11244422_134444_john
1234322_1234431 john
1234222_134322-john
12422344_12453222";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}