import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d+(?:_\\d+)?(?:_[A-Za-z]+)?$";
final String string = "1234567890\n"
+ "1234567890_Alphabet\n"
+ "1234567890 - Alphabet\n"
+ "1234567890alphabet\n\n\n"
+ "The string should start as numeric but not alphabet. i.e. Numeric only\n"
+ "Underscore(_) preceded by numbers.\n\n\n"
+ "11244422_134444_john\n"
+ "1234322_1234431 john\n"
+ "1234222_134322-john\n"
+ "12422344_12453222";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}