// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d+(?:_\d+)?(?:_[A-Za-z]+)?$").unwrap();
let string = "1234567890
1234567890_Alphabet
1234567890 - Alphabet
1234567890alphabet
The string should start as numeric but not alphabet. i.e. Numeric only
Underscore(_) preceded by numbers.
11244422_134444_john
1234322_1234431 john
1234222_134322-john
12422344_12453222";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}