import Foundation
let pattern = #"^\d+(?:_\d+)?(?:_[A-Za-z]+)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1234567890
1234567890_Alphabet
1234567890 - Alphabet
1234567890alphabet
The string should start as numeric but not alphabet. i.e. Numeric only
Underscore(_) preceded by numbers.
11244422_134444_john
1234322_1234431 john
1234222_134322-john
12422344_12453222
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)