#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\[ext_resource path="res:\/\/mods-unpacked\/Darkly77-Invasion\/([A-z0-9_!-\/]+)\/([A-z0-9_!-]+).png"
Local $sString = "[ext_resource path="res://mods-unpacked/Darkly77-Invasion/content/items/abyssal_pact/abyssal_pact.png" type="Texture" id=1]" & @CRLF & _
"[ext_resource path="res://mods-unpacked/Darkly77-Invasion/content/weapons/melee/big_hand/big_hand_icon.png" type="Texture" id=5]" & @CRLF & _
"[ext_resource path="res://mods-unpacked/Darkly77-Invasion/content/weapons/melee/big_hand/big_hand.png" type="Texture" id=3]" & @CRLF & _
"[ext_resource path="res://mods-unpacked/Darkly77-Invasion/content/weapons/ranged/clone/clone_x4_inactive.png" type="Texture" id=6]" & @CRLF & _
"[ext_resource path="res://mods-unpacked/Darkly77-Invasion/content/weapons/ranged/clone/clone_x4.png" type="Texture" id=1]" & @CRLF & _
"[ext_resource path="res://mods-unpacked/Darkly77-Invasion/content/weapons/ranged/dstick/projectile/dstick_projectile.png" type="Texture" id=2]" & @CRLF & _
"" & @CRLF & _
"[ext_resource path="res://mods-unpacked/Darkly77-Invasion/content/!items-todo/!drone/drone.png" type="Texture" id=1]" & @CRLF & _
"" & @CRLF & _
"[ext_resource path="res://mods-unpacked/Darkly77-Invasion/content/!items-todo/!demonic_totem/demonic_totem.png" type="Texture" id=1]" & @CRLF & _
"" & @CRLF & _
"[ext_resource path="res://mods-unpacked/Darkly77-Invasion/content/items-todo/drone/drone.png" type="Texture" id=1]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")