const regex = /\[ext_resource path="res:\/\/mods-unpacked\/Darkly77-Invasion\/([A-z0-9_!-\/]+)\/([A-z0-9_!-]+).png/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[ext_resource path="res:\\\/\\\/mods-unpacked\\\/Darkly77-Invasion\\\/([A-z0-9_!-\\\/]+)\\\/([A-z0-9_!-]+).png', 'gm')
const str = `[ext_resource path="res://mods-unpacked/Darkly77-Invasion/content/items/abyssal_pact/abyssal_pact.png" type="Texture" id=1]
[ext_resource path="res://mods-unpacked/Darkly77-Invasion/content/weapons/melee/big_hand/big_hand_icon.png" type="Texture" id=5]
[ext_resource path="res://mods-unpacked/Darkly77-Invasion/content/weapons/melee/big_hand/big_hand.png" type="Texture" id=3]
[ext_resource path="res://mods-unpacked/Darkly77-Invasion/content/weapons/ranged/clone/clone_x4_inactive.png" type="Texture" id=6]
[ext_resource path="res://mods-unpacked/Darkly77-Invasion/content/weapons/ranged/clone/clone_x4.png" type="Texture" id=1]
[ext_resource path="res://mods-unpacked/Darkly77-Invasion/content/weapons/ranged/dstick/projectile/dstick_projectile.png" type="Texture" id=2]
[ext_resource path="res://mods-unpacked/Darkly77-Invasion/content/!items-todo/!drone/drone.png" type="Texture" id=1]
[ext_resource path="res://mods-unpacked/Darkly77-Invasion/content/!items-todo/!demonic_totem/demonic_totem.png" type="Texture" id=1]
[ext_resource path="res://mods-unpacked/Darkly77-Invasion/content/items-todo/drone/drone.png" type="Texture" id=1]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}