$re = '/\[ext_resource path="res:\/\/mods-unpacked\/Darkly77-Invasion\/([A-z0-9_!-\/]+)\/([A-z0-9_!-]+).png/m';
$str = '[ext_resource path="res://mods-unpacked/Darkly77-Invasion/content/items/abyssal_pact/abyssal_pact.png" type="Texture" id=1]
[ext_resource path="res://mods-unpacked/Darkly77-Invasion/content/weapons/melee/big_hand/big_hand_icon.png" type="Texture" id=5]
[ext_resource path="res://mods-unpacked/Darkly77-Invasion/content/weapons/melee/big_hand/big_hand.png" type="Texture" id=3]
[ext_resource path="res://mods-unpacked/Darkly77-Invasion/content/weapons/ranged/clone/clone_x4_inactive.png" type="Texture" id=6]
[ext_resource path="res://mods-unpacked/Darkly77-Invasion/content/weapons/ranged/clone/clone_x4.png" type="Texture" id=1]
[ext_resource path="res://mods-unpacked/Darkly77-Invasion/content/weapons/ranged/dstick/projectile/dstick_projectile.png" type="Texture" id=2]
[ext_resource path="res://mods-unpacked/Darkly77-Invasion/content/!items-todo/!drone/drone.png" type="Texture" id=1]
[ext_resource path="res://mods-unpacked/Darkly77-Invasion/content/!items-todo/!demonic_totem/demonic_totem.png" type="Texture" id=1]
[ext_resource path="res://mods-unpacked/Darkly77-Invasion/content/items-todo/drone/drone.png" type="Texture" id=1]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);