import Foundation
let pattern = #"\[ext_resource path="res:\/\/mods-unpacked\/Darkly77-Invasion\/([A-z0-9_!-\/]+)\/([A-z0-9_!-]+).png"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
[ext_resource path="res://mods-unpacked/Darkly77-Invasion/content/items/abyssal_pact/abyssal_pact.png" type="Texture" id=1]
[ext_resource path="res://mods-unpacked/Darkly77-Invasion/content/weapons/melee/big_hand/big_hand_icon.png" type="Texture" id=5]
[ext_resource path="res://mods-unpacked/Darkly77-Invasion/content/weapons/melee/big_hand/big_hand.png" type="Texture" id=3]
[ext_resource path="res://mods-unpacked/Darkly77-Invasion/content/weapons/ranged/clone/clone_x4_inactive.png" type="Texture" id=6]
[ext_resource path="res://mods-unpacked/Darkly77-Invasion/content/weapons/ranged/clone/clone_x4.png" type="Texture" id=1]
[ext_resource path="res://mods-unpacked/Darkly77-Invasion/content/weapons/ranged/dstick/projectile/dstick_projectile.png" type="Texture" id=2]
[ext_resource path="res://mods-unpacked/Darkly77-Invasion/content/!items-todo/!drone/drone.png" type="Texture" id=1]
[ext_resource path="res://mods-unpacked/Darkly77-Invasion/content/!items-todo/!demonic_totem/demonic_totem.png" type="Texture" id=1]
[ext_resource path="res://mods-unpacked/Darkly77-Invasion/content/items-todo/drone/drone.png" type="Texture" id=1]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)