# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\[ext_resource path=\"res:\/\/mods-unpacked\/Darkly77-Invasion\/([A-z0-9_!-\/]+)\/([A-z0-9_!-]+).png"
test_str = ("[ext_resource path=\"res://mods-unpacked/Darkly77-Invasion/content/items/abyssal_pact/abyssal_pact.png\" type=\"Texture\" id=1]\n"
"[ext_resource path=\"res://mods-unpacked/Darkly77-Invasion/content/weapons/melee/big_hand/big_hand_icon.png\" type=\"Texture\" id=5]\n"
"[ext_resource path=\"res://mods-unpacked/Darkly77-Invasion/content/weapons/melee/big_hand/big_hand.png\" type=\"Texture\" id=3]\n"
"[ext_resource path=\"res://mods-unpacked/Darkly77-Invasion/content/weapons/ranged/clone/clone_x4_inactive.png\" type=\"Texture\" id=6]\n"
"[ext_resource path=\"res://mods-unpacked/Darkly77-Invasion/content/weapons/ranged/clone/clone_x4.png\" type=\"Texture\" id=1]\n"
"[ext_resource path=\"res://mods-unpacked/Darkly77-Invasion/content/weapons/ranged/dstick/projectile/dstick_projectile.png\" type=\"Texture\" id=2]\n\n"
"[ext_resource path=\"res://mods-unpacked/Darkly77-Invasion/content/!items-todo/!drone/drone.png\" type=\"Texture\" id=1]\n\n"
"[ext_resource path=\"res://mods-unpacked/Darkly77-Invasion/content/!items-todo/!demonic_totem/demonic_totem.png\" type=\"Texture\" id=1]\n\n"
"[ext_resource path=\"res://mods-unpacked/Darkly77-Invasion/content/items-todo/drone/drone.png\" type=\"Texture\" id=1]")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.