import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[ext_resource path=\"res:\\/\\/mods-unpacked\\/Darkly77-Invasion\\/([A-z0-9_!-\\/]+)\\/([A-z0-9_!-]+).png";
final String string = "[ext_resource path=\"res://mods-unpacked/Darkly77-Invasion/content/items/abyssal_pact/abyssal_pact.png\" type=\"Texture\" id=1]\n"
+ "[ext_resource path=\"res://mods-unpacked/Darkly77-Invasion/content/weapons/melee/big_hand/big_hand_icon.png\" type=\"Texture\" id=5]\n"
+ "[ext_resource path=\"res://mods-unpacked/Darkly77-Invasion/content/weapons/melee/big_hand/big_hand.png\" type=\"Texture\" id=3]\n"
+ "[ext_resource path=\"res://mods-unpacked/Darkly77-Invasion/content/weapons/ranged/clone/clone_x4_inactive.png\" type=\"Texture\" id=6]\n"
+ "[ext_resource path=\"res://mods-unpacked/Darkly77-Invasion/content/weapons/ranged/clone/clone_x4.png\" type=\"Texture\" id=1]\n"
+ "[ext_resource path=\"res://mods-unpacked/Darkly77-Invasion/content/weapons/ranged/dstick/projectile/dstick_projectile.png\" type=\"Texture\" id=2]\n\n"
+ "[ext_resource path=\"res://mods-unpacked/Darkly77-Invasion/content/!items-todo/!drone/drone.png\" type=\"Texture\" id=1]\n\n"
+ "[ext_resource path=\"res://mods-unpacked/Darkly77-Invasion/content/!items-todo/!demonic_totem/demonic_totem.png\" type=\"Texture\" id=1]\n\n"
+ "[ext_resource path=\"res://mods-unpacked/Darkly77-Invasion/content/items-todo/drone/drone.png\" type=\"Texture\" id=1]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}