#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)<a.*?>\s*([^<\s](?:[^<]*[^<\s])*)\s*<"
Local $sString = "<ul>" & @CRLF & _
" <li><a href="https://www.google.ru/?q=Darth+Vader">Darth Vader</a></li>" & @CRLF & _
" <li><a href="https://www.google.ru/?q=Anakin+Skywalker">Anakin Skywalker</a></li>" & @CRLF & _
"</ul>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")