using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a.*?>\s*([^<\s](?:[^<]*[^<\s])*)\s*<";
string input = @"<ul>
<li><a href=""https://www.google.ru/?q=Darth+Vader"">Darth Vader</a></li>
<li><a href=""https://www.google.ru/?q=Anakin+Skywalker"">Anakin Skywalker</a></li>
</ul>";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}