// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)<a.*?>\s*([^<\s](?:[^<]*[^<\s])*)\s*<").unwrap();
let string = "<ul>
<li><a href=\"https://www.google.ru/?q=Darth+Vader\">Darth Vader</a></li>
<li><a href=\"https://www.google.ru/?q=Anakin+Skywalker\">Anakin Skywalker</a></li>
</ul>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}