package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)<a.*?>\s*([^<\s](?:[^<]*[^<\s])*)\s*<`)
var str = `<ul>
<li><a href="https://www.google.ru/?q=Darth+Vader">Darth Vader</a></li>
<li><a href="https://www.google.ru/?q=Anakin+Skywalker">Anakin Skywalker</a></li>
</ul>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}