re = /<a.*?>\s*([^<\s](?:[^<]*[^<\s])*)\s*</i
str = '<ul>
<li><a href="https://www.google.ru/?q=Darth+Vader">Darth Vader</a></li>
<li><a href="https://www.google.ru/?q=Anakin+Skywalker">Anakin Skywalker</a></li>
</ul>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end