#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)!?\b(?<action>startswith|endswith|contains|equals)\((?<field>\w+),(?<value>\w+)\)"
Local $sString = "contains(field,value) OK" & @CRLF & _
"startswith(field,value) OK" & @CRLF & _
"test(field,value) NOK (test is not a valid keyword)" & @CRLF & _
"equals(field,value) OK" & @CRLF & _
"!startswith(field,value) OK (optional character ! allowed)" & @CRLF & _
"!contains(field,value) OK (optional character ! allowed)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")