const regex = /!?\b(?<action>startswith|endswith|contains|equals)\((?<field>\w+),(?<value>\w+)\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('!?\\b(?<action>startswith|endswith|contains|equals)\\((?<field>\\w+),(?<value>\\w+)\\)', 'gm')
const str = `contains(field,value) OK
startswith(field,value) OK
test(field,value) NOK (test is not a valid keyword)
equals(field,value) OK
!startswith(field,value) OK (optional character ! allowed)
!contains(field,value) OK (optional character ! allowed)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}