import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "!?\\b(?<action>startswith|endswith|contains|equals)\\((?<field>\\w+),(?<value>\\w+)\\)";
final String string = "contains(field,value) OK\n"
+ "startswith(field,value) OK\n"
+ "test(field,value) NOK (test is not a valid keyword)\n"
+ "equals(field,value) OK\n"
+ "!startswith(field,value) OK (optional character ! allowed)\n"
+ "!contains(field,value) OK (optional character ! allowed)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}