package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)!?\b(?<action>startswith|endswith|contains|equals)\((?<field>\w+),(?<value>\w+)\)`)
var str = `contains(field,value) OK
startswith(field,value) OK
test(field,value) NOK (test is not a valid keyword)
equals(field,value) OK
!startswith(field,value) OK (optional character ! allowed)
!contains(field,value) OK (optional character ! allowed)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}