$re = '/!?\b(?<action>startswith|endswith|contains|equals)\((?<field>\w+),(?<value>\w+)\)/m';
$str = 'contains(field,value) OK
startswith(field,value) OK
test(field,value) NOK (test is not a valid keyword)
equals(field,value) OK
!startswith(field,value) OK (optional character ! allowed)
!contains(field,value) OK (optional character ! allowed)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);