re = /!?\b(?<action>startswith|endswith|contains|equals)\((?<field>\w+),(?<value>\w+)\)/m
str = 'contains(field,value) OK
startswith(field,value) OK
test(field,value) NOK (test is not a valid keyword)
equals(field,value) OK
!startswith(field,value) OK (optional character ! allowed)
!contains(field,value) OK (optional character ! allowed)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end