#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\/(?!\.well-known\/).*"
Local $sString = "/.well-known/acme-challenge" & @CRLF & _
"/.well-known/acme-challenge/" & @CRLF & _
"/.well-known/acme-challenge/12312312sffsdaf" & @CRLF & _
"/" & @CRLF & _
"/some-page" & @CRLF & _
"/some-page/cool"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")