re = /^\/(?!\.well-known\/).*/m
str = '/.well-known/acme-challenge
/.well-known/acme-challenge/
/.well-known/acme-challenge/12312312sffsdaf
/
/some-page
/some-page/cool'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end