$re = '/^\/(?!\.well-known\/).*/m';
$str = '/.well-known/acme-challenge
/.well-known/acme-challenge/
/.well-known/acme-challenge/12312312sffsdaf
/
/some-page
/some-page/cool';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);