import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\/(?!\\.well-known\\/).*";
final String string = "/.well-known/acme-challenge\n"
+ "/.well-known/acme-challenge/\n"
+ "/.well-known/acme-challenge/12312312sffsdaf\n"
+ "/\n"
+ "/some-page\n"
+ "/some-page/cool";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}