const regex = /^\/(?!\.well-known\/).*/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\\/(?!\\.well-known\\\/).*', 'mg')
const str = `/.well-known/acme-challenge
/.well-known/acme-challenge/
/.well-known/acme-challenge/12312312sffsdaf
/
/some-page
/some-page/cool`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}