import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\G(?!^)|^(?=.*string3)).*?\\Kstring1";
final String string = "This is line string1\n"
+ "This is line two with string1 and string3 string1\n"
+ "This is line two with string1 string1 and string3 \n"
+ "This is line three with string3\n"
+ "This is line string3 with string1 and string1";
final String subst = "string2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}