re = /(?:\G(?!^)|^(?=.*string3)).*?\Kstring1/m
str = 'This is line string1
This is line two with string1 and string3 string1
This is line two with string1 string1 and string3
This is line three with string3
This is line string3 with string1 and string1'
subst = 'string2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result