import re
regex = re.compile(r"(?:\G(?!^)|^(?=.*string3)).*?\Kstring1", flags=re.MULTILINE)
test_str = ("This is line string1\n"
"This is line two with string1 and string3 string1\n"
"This is line two with string1 string1 and string3 \n"
"This is line three with string3\n"
"This is line string3 with string1 and string1")
subst = "string2"
result = regex.sub(subst, test_str)
if result:
print(result)