import Foundation
let pattern = #"(?:\G(?!^)|^(?=.*string3)).*?\Kstring1"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
This is line string1
This is line two with string1 and string3 string1
This is line two with string1 string1 and string3
This is line three with string3
This is line string3 with string1 and string1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"string2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)