const regex = /(?:\G(?!^)|^(?=.*string3)).*?\Kstring1/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\G(?!^)|^(?=.*string3)).*?\\Kstring1', 'gm')
const str = `This is line string1
This is line two with string1 and string3 string1
This is line two with string1 string1 and string3
This is line three with string3
This is line string3 with string1 and string1`;
const subst = `string2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);