using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!dist\/|bower_components\/).+$";
string input = @".bowerrc
.editorconfig
.eslintrc
.yo-rc.json
bower.json
bower_components/angular/.bower.json
bower_components/angular/angular-csp.css
bower_components/angular/angular.js
bower_components/angular/angular.min.js
bower_components/angular/angular.min.js.gzip
bower_components/angular/angular.min.js.map
dist/assets/images/karma.png
dist/assets/images/node-sass.png
dist/assets/images/protractor.png
dist/assets/images/yeoman.png
dist/cabecalho_financiamento.html
dist/css/materialize.css.map
dist/css/style.css.map
dist/favicon.ico
dist/font/fira/fira-bold-italic.eot
dist/font/fira/fira-bold-italic.svg
dist/font/fira/fira-bold-italic.ttf
dist/font/fira/fira-bold-italic.woff
src/font/fira/fira-bold-italic.eot
src/font/fira/fira-bold-italic.svg
src/font/fira/fira-bold-italic.ttf
src/font/fira/fira-bold-italic.woff
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}