const regex = /^(?!dist\/|bower_components\/).+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!dist\\\/|bower_components\\\/).+$', 'gm')
const str = `.bowerrc
.editorconfig
.eslintrc
.yo-rc.json
bower.json
bower_components/angular/.bower.json
bower_components/angular/angular-csp.css
bower_components/angular/angular.js
bower_components/angular/angular.min.js
bower_components/angular/angular.min.js.gzip
bower_components/angular/angular.min.js.map
dist/assets/images/karma.png
dist/assets/images/node-sass.png
dist/assets/images/protractor.png
dist/assets/images/yeoman.png
dist/cabecalho_financiamento.html
dist/css/materialize.css.map
dist/css/style.css.map
dist/favicon.ico
dist/font/fira/fira-bold-italic.eot
dist/font/fira/fira-bold-italic.svg
dist/font/fira/fira-bold-italic.ttf
dist/font/fira/fira-bold-italic.woff
src/font/fira/fira-bold-italic.eot
src/font/fira/fira-bold-italic.svg
src/font/fira/fira-bold-italic.ttf
src/font/fira/fira-bold-italic.woff
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}