# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?!dist\/|bower_components\/).+$"
test_str = (".bowerrc\n"
".editorconfig\n"
".eslintrc\n"
".yo-rc.json\n"
"bower.json\n"
"bower_components/angular/.bower.json\n"
"bower_components/angular/angular-csp.css\n"
"bower_components/angular/angular.js\n"
"bower_components/angular/angular.min.js\n"
"bower_components/angular/angular.min.js.gzip\n"
"bower_components/angular/angular.min.js.map\n"
"dist/assets/images/karma.png\n"
"dist/assets/images/node-sass.png\n"
"dist/assets/images/protractor.png\n"
"dist/assets/images/yeoman.png\n"
"dist/cabecalho_financiamento.html\n"
"dist/css/materialize.css.map\n"
"dist/css/style.css.map\n"
"dist/favicon.ico\n"
"dist/font/fira/fira-bold-italic.eot\n"
"dist/font/fira/fira-bold-italic.svg\n"
"dist/font/fira/fira-bold-italic.ttf\n"
"dist/font/fira/fira-bold-italic.woff\n"
"src/font/fira/fira-bold-italic.eot\n"
"src/font/fira/fira-bold-italic.svg\n"
"src/font/fira/fira-bold-italic.ttf\n"
"src/font/fira/fira-bold-italic.woff\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.