import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!dist\\/|bower_components\\/).+$";
final String string = ".bowerrc\n"
+ ".editorconfig\n"
+ ".eslintrc\n"
+ ".yo-rc.json\n"
+ "bower.json\n"
+ "bower_components/angular/.bower.json\n"
+ "bower_components/angular/angular-csp.css\n"
+ "bower_components/angular/angular.js\n"
+ "bower_components/angular/angular.min.js\n"
+ "bower_components/angular/angular.min.js.gzip\n"
+ "bower_components/angular/angular.min.js.map\n"
+ "dist/assets/images/karma.png\n"
+ "dist/assets/images/node-sass.png\n"
+ "dist/assets/images/protractor.png\n"
+ "dist/assets/images/yeoman.png\n"
+ "dist/cabecalho_financiamento.html\n"
+ "dist/css/materialize.css.map\n"
+ "dist/css/style.css.map\n"
+ "dist/favicon.ico\n"
+ "dist/font/fira/fira-bold-italic.eot\n"
+ "dist/font/fira/fira-bold-italic.svg\n"
+ "dist/font/fira/fira-bold-italic.ttf\n"
+ "dist/font/fira/fira-bold-italic.woff\n"
+ "src/font/fira/fira-bold-italic.eot\n"
+ "src/font/fira/fira-bold-italic.svg\n"
+ "src/font/fira/fira-bold-italic.ttf\n"
+ "src/font/fira/fira-bold-italic.woff\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}