use strict;
my $str = '.bowerrc
.editorconfig
.eslintrc
.yo-rc.json
bower.json
bower_components/angular/.bower.json
bower_components/angular/angular-csp.css
bower_components/angular/angular.js
bower_components/angular/angular.min.js
bower_components/angular/angular.min.js.gzip
bower_components/angular/angular.min.js.map
dist/assets/images/karma.png
dist/assets/images/node-sass.png
dist/assets/images/protractor.png
dist/assets/images/yeoman.png
dist/cabecalho_financiamento.html
dist/css/materialize.css.map
dist/css/style.css.map
dist/favicon.ico
dist/font/fira/fira-bold-italic.eot
dist/font/fira/fira-bold-italic.svg
dist/font/fira/fira-bold-italic.ttf
dist/font/fira/fira-bold-italic.woff
src/font/fira/fira-bold-italic.eot
src/font/fira/fira-bold-italic.svg
src/font/fira/fira-bold-italic.ttf
src/font/fira/fira-bold-italic.woff
';
my $regex = qr/^(?!dist\/|bower_components\/).+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}