const regex = /(?<=\\\\r\\\\n)(?:(?!\\\\r\\\\n)[\w\W])*?(?=\\\\r\\\\n=)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\\\\\\\r\\\\\\\\n)(?:(?!\\\\\\\\r\\\\\\\\n)[\\w\\W])*?(?=\\\\\\\\r\\\\\\\\n=)', 'gm')
const str = `# Heading Level 1\\\\r\\\\n## Heading Level 2\\\\r\\\\n### Heading
Level 3\\\\r\\\\n#### Heading Level
4\\\\r\\\\n##### Heading Level 5\\\\r\\\\n###### Heading Level 6\\\\r\\\\nHeading Level 13
Alternate\\\\r\\\\n======================\\\\r\\\\n`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}