re = /(?<=\\\\r\\\\n)(?:(?!\\\\r\\\\n)[\w\W])*?(?=\\\\r\\\\n=)/m
str = '# Heading Level 1\\\\r\\\\n## Heading Level 2\\\\r\\\\n### Heading
Level 3\\\\r\\\\n#### Heading Level
4\\\\r\\\\n##### Heading Level 5\\\\r\\\\n###### Heading Level 6\\\\r\\\\nHeading Level 13
Alternate\\\\r\\\\n======================\\\\r\\\\n'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end