$re = '/(?<=\\\\\\\\r\\\\\\\\n)(?:(?!\\\\\\\\r\\\\\\\\n)[\w\W])*?(?=\\\\\\\\r\\\\\\\\n=)/m';
$str = '# Heading Level 1\\\\r\\\\n## Heading Level 2\\\\r\\\\n### Heading
Level 3\\\\r\\\\n#### Heading Level
4\\\\r\\\\n##### Heading Level 5\\\\r\\\\n###### Heading Level 6\\\\r\\\\nHeading Level 13
Alternate\\\\r\\\\n======================\\\\r\\\\n';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);