#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)a\.b(\((?>[^()]++|(?1))*\))"
Local $sString = "a.b();" & @CRLF & _
"a.b(param1=1);" & @CRLF & _
"a.b(param1=1, param2=2);" & @CRLF & _
"a.b(param1=d(abc="123"))"
Local $sSubst = "$0.c()"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)