import Foundation
let pattern = #"a\.b(\((?>[^()]++|(?1))*\))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
a.b();
a.b(param1=1);
a.b(param1=1, param2=2);
a.b(param1=d(abc="123"))
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$0.c()"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)