const regex = /a\.b(\((?>[^()]++|(?1))*\))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('a\\.b(\\((?>[^()]++|(?1))*\\))', 'gm')
const str = `a.b();
a.b(param1=1);
a.b(param1=1, param2=2);
a.b(param1=d(abc="123"))`;
const subst = `$0.c()`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);