use strict;
my $str = 'a.b();
a.b(param1=1);
a.b(param1=1, param2=2);
a.b(param1=d(abc="123"))';
my $regex = qr/a\.b(\((?>[^()]++|(?1))*\))/mp;
my $subst = '$0.c()';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";