re = /a\.b(\((?>[^()]++|(?1))*\))/m
str = 'a.b();
a.b(param1=1);
a.b(param1=1, param2=2);
a.b(param1=d(abc="123"))'
subst = '$0.c()'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result