using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"a\.b(\((?>[^()]++|(?1))*\))";
string substitution = @"$0.c()";
string input = @"a.b();
a.b(param1=1);
a.b(param1=1, param2=2);
a.b(param1=d(abc=""123""))";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}