using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Phone:\s*\({0,1}(\d{3})\){0,1}\s*(\d{3})-*(\d{4})\n{0,1}";
string input = @"Phone: (630) 690-0336\nFax: (630) 355-0197
Phone: (630) 6900336\nFax: (630) 355-0197
Fax: (630) 355-0197\nPhone: (630) 6900336";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}