import Foundation
let pattern = #"Phone:\s*\({0,1}(\d{3})\){0,1}\s*(\d{3})-*(\d{4})\n{0,1}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Phone: (630) 690-0336\nFax: (630) 355-0197
Phone: (630) 6900336\nFax: (630) 355-0197
Fax: (630) 355-0197\nPhone: (630) 6900336
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)