// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"Phone:\s*\({0,1}(\d{3})\){0,1}\s*(\d{3})-*(\d{4})\n{0,1}").unwrap();
let string = "Phone: (630) 690-0336\\nFax: (630) 355-0197
Phone: (630) 6900336\\nFax: (630) 355-0197
Fax: (630) 355-0197\\nPhone: (630) 6900336";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}